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ABBREVIATIONS
Abbreviation
CPU
GPU
eGPU
dGPU
iGPU
USB-C
PCIe
App
VR
3D

Description
Central Processing Unit (processor)
Graphics Processing Unit
External Graphics Processing Unit (connected via Thunderbolt)
Discrete Graphics Processing Unit (inside laptop)
Integrated Graphics Processing Unit (part of CPU)
Universal Serial Bus with Type-C Connector
Peripheral Component Interconnect Express
Application (computer program)
Virtual Reality
Three Dimensional
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GENERAL INFORMATION
External graphics using AMD® graphics chips is supported on all Thunderbolt TM 3 enabled Intel based Macs. NVIDIA® graphics chips are
not externally supported by macOS. Mac computers with a first- or second-generation Thunderbolt interface do not support external graphics.
Only Thunderbolt 3 machines running the latest version of macOS High Sierra, macOS Mojave, macOS Catalina, macOS Big Sur, or macOS
Monterey support external graphics. Starting with macOS Mojave, the user can accelerate applications on the built-in display. We recommend
using the latest macOS operating system for the best eGPU experience.

Note: Only a Thunderbolt 3 Mac with an Intel CPU supports external graphics.
Macs with an Apple CPU (M1 Max / M1 Pro / M1) do not work with an eGPU.
In general, Thunderbolt 3 enabled Macs have either two or four USB-C type connectors (see Figure 1). The MacBook (identifier: 8,1/ 9,1
and 10,1) with a single USB-C port does not support external graphics. This computer has a USB—not Thunderbolt 3—interface (see
Figure 2).

Figure 1: Two or four USB-C type connectors indicate a MacBook Pro or MacBook Air with Thunderbolt ports.

Figure 2: A single USB-C type connector indicates a MacBook with a USB 3 port. This is not a Thunderbolt port.

Only a Thunderbolt 3 port connected with a Thunderbolt 3 or 4 cable supports external graphics. Make sure that you use a Thunderbolt
cable with the Thunderbolt trademark logo (see Figure 3). Cables that do not have this logo are regular USB-C cables which do not work.

Figure 3: Apple® (left) and Sonnet (right) Thunderbolt cables with Thunderbolt logo.
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In order to get the best performance out of your external graphics processor, always make sure to connect it directly to the Thunderbolt port
on your Mac.
An eGPU lets you do the following on your Mac:
•
•
•
•
•
•
•
•
•

Accelerate apps that use Metal, OpenGL, and OpenCL
Connect additional external monitors and displays
Use virtual reality headsets plugged into the eGPU
Charge your MacBook Pro or MacBook Air while using the eGPU*
Use an eGPU with your MacBook Pro or MacBook Air while its built-in display is closed
Connect an eGPU while a user is logged in
Connect more than one eGPU using the multiple Thunderbolt 3 (USB-C) ports on your Mac
Use the menu bar item
to safely disconnect the eGPU
View the activity levels of built-in and external GPUs (Open Activity Monitor, then choose Window > GPU History)

In general, an eGPU can accelerate performance in these types of apps:
•
•
•
•

Pro apps designed to utilize multiple GPUs
3D games, either on the internal display or on an external monitor that is attached directly to the eGPU (Tip: use an external monitor
for best performance)
VR apps, when the VR headset is attached directly to the eGPU
Pro apps and 3D games that accelerate the built-in display of iMac, iMac Pro, MacBook Air, and MacBook Pro (This capability must
be enabled by the app's developer).

*Note: Starting in December 2020, the laptop charging power has been reduced to less than 100W to meet IEC 62368 requirements.
Laptop Charging Power

Sonnet Part Number

Product Name

15W

GPU-350W-TB3Z
DM-MOD-GPU
GPU-RX560-TB3-S
GPU-RX570-TB3-S
GPU-350W-TB3DEK
GPU-RX55-TB3-S
GPU-RX57-TB3-S
GPU-750W-TB3
GPU-750EX-TB3

eGFX Breakaway Box
DuoModo eGPU Module
eGFX Breakaway Puck Radeon RX 560
eGFX Breakaway Puck Radeon RX 570
eGFX Breakaway Box Developer Edition
eGPU Breakaway Puck Radeon RX 5500 XT
eGPU Breakaway Puck Radeon RX 5700
eGPU Breakaway Box 750
eGPU Breakaway Box 750ex

GPU-550W-TB3
GPU-650W-TB3
GPU-650OC-TB3

eGFX Breakaway Box 550
eGFX Breakaway Box 650
eGFX Breakaway Box 650 OC

60W

85W
87W
100W
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SETTING UP EXTERNAL GRAPHICS (EGPU)
1. Choose either a Sonnet eGPU Breakaway Puck or an eGPU Breakaway Box. If you select an eGPU Breakaway Box, choose a
compatible graphics card. Check our Graphics Card Compatibility Chart to find the right card.
2. If you have an eGPU Breakaway Box, open the Box and install your AMD card. Plug the auxiliary power connector(s) into the card.
Close the Box. Plug the Box or Puck into the power outlet. Turn on the power switch if the Box has one.
3. Connect the eGPU device to your computer with the included Thunderbolt 3 cable. The blue light on the device will not turn on until
you connect the eGPU to a computer which is powered on. There is no need to install any drivers. Beginning with macOS Mojave
(10.14), a graphics processor symbol will appear in the menu bar (see Figure 4). Click on this symbol to see which graphics processor
has been connected, or to safe disconnect the eGPU.

Figure 4: External graphics symbol in macOS menu bar.
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MANUALLY SELECTING THE EXTERNAL GRAPHICS PROCESSOR (EGPU)
Beginning with macOS Mojave (10.14), you can turn on Prefer External GPU in a specific app's Get Info panel in the Finder (see Figure
5). This option lets the eGPU accelerate apps on any display connected to the Mac—including displays built into your iMac, iMac
Pro, MacBook Air, and MacBook Pro.

Note for Professionals:
Some professional apps do not require you to use the Prefer External GPU feature. Avoid using the Prefer External GPU feature
with Adobe Premiere Pro and After Effects, Blackmagic Design DaVinci Resolve and Apple Final Cut Pro X.
•
•
•
•

Premiere Pro and After Effects chooses one or multiple GPUs automatically.
In DaVinci Resolve, the user may have to select the external GPU(s) under Preferences > Hardw are Configuration > GPU
Processing Mode: Metal / GPU Selection Mode: Manual.
In Final Cut Pro X, the user can select the external GPU under Preferences > Playback > Render/Share GPU.
Connect an external monitor to your eGPU and set it as your primary dis play to achieve the best performance.
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Prefer External GPU for apps in the Applications folder

Figure 5: Select the Prefer External GPU feature.

1. Quit the app if it's open.
2. Select the app in the Finder; most apps are in your Applications folder. If you open the app from an alias or launcher, Controlclick the app’s icon and choose Options > Show in Finder from the pop-up menu, and then select the original app.
3. Press Command-I to show the app's info window.
4. Select the checkbox next to Prefer External GPU (see Figure 5).
5. Open the app to use it with the eGPU.
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Prefer External GPU for Steam games

Figure 6: Use the Prefer External GPU feature with Steam games.

1. For Steam games (See Figure 6), quit the app if it's open.
2. Open Steam and navigate to Library > Mac. Right-click on your game and select Properties > Local Files > Browse Local Files.
Finder will open and display the application launcher for your game.
3. Press Command-I to show the app's info window
4. Select the checkbox next to Prefer External GPU.
5. Open the app to use it with the eGPU.
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SETTING AN EGPU DISPLAY AS THE PRIMARY DISPLAY
If you have an external display connected to your eGPU, you can set it to be the primary display for all apps. Since apps default to the GPU
associated with the primary display, this option works with a variety of apps:
1.
2.
3.
4.

Quit any open apps that you want the eGPU to accelerate on the primary display.
Choose Apple menu > System Preferences. Select Displays, then select the Arrangement tab.
Drag the white menu bar to the box that represents the display that's attached to the eGPU (see Figure 7).
Open the apps that you want to use with the eGPU.

If you disconnect the eGPU, your Mac defaults back to the internal graphics processors that drives the built-in display. When the eGPU is reattached, it automatically sets the external display as the primary display.

Figure 7: Set the eGPU display as primary display.
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UNDERSTANDING HOW A GPU IMPACTS A PROFESSIONAL WORKFLOW
Not all software uses a graphics processor to accelerate features or effects within the application. Check your workflow to see if it actually makes use of
a GPU. In Adobe Premiere Pro and After Effects, one can filter the Effects tab for GPU accelerated effects. Watch this Adobe video to learn more about
using eGPUs with Premiere Pro.
The actual performance of your workflow depends on more than just your graphics processor. Amongst other factors, your CPU and System Memory are
just as important as your GPU. Use the Activity Monitor application to analyze your CPU, System Memory and GPU usage.
Note: An external GPU can help to accelerate your workflow when your computer’s built-in GPU is reaching its performance limit while your
computer’s CPU and system memory have plenty of resources available.

An eGPU can accelerate this workflow – the built-in GPU is limiting the overall performance of this system:

Figure 9: Discrete GPU limiting
the overall performance of the
system.

Figure 8: CPU idling with plenty of resources available.
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Figure 10: Plenty of system memory available.

An eGPU cannot accelerate this workflow – the CPU is limiting the overall performance of this system:

Figure 12: GPU performance
limited by CPU bottleneck.

Figure 13: CPU limiting the overall performance of the system.
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Figure 11: Plenty of system memory available.

TROUBLESHOOTING
If your external graphics device isn’t working correctly, please check the following.
•

Make sure the Thunderbolt interface of your eGPU product is being detected. Press Command and Space Bar at the same time and
enter “System Information”. Open this app and navigate to the Thunderbolt entry. Check if your eGPU device is listed (see Figure 14).
If it is not being detected, check the following.
◦ Did you connect the power cable(s) to all the auxiliary power connector(s) at the top or rear of the card? If not, the card will not
show up.
◦ Is the wall power cable connected, the power switch on (not all eGPU Breakaway Boxes have a switch), and the Thunderbolt
cable connected? If not all of the above, the eGPU device will not turn on.
◦ Are you using a Thunderbolt cable? Look for the Thunderbolt logo on the connectors (see Figure 3).
◦ Could the Thunderbolt cable be defective? Try a different Thunderbolt 3 or 4 cable.

Figure 14: System Information detecting the eGPU Thunderbolt device.
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•

If your Sonnet eGPU product appears in the Thunderbolt entry (see above), try to find your external GPU in the PCI entry of the
System Information application (see Figure 15).
◦ If you can find your eGPU listed in the PCI entry but under “Driver Installed” it says “No”, then your eGPU is not supported. Newer
cards may require a newer version of macOS for driver support (for example, a Radeon RX 5500 XT requires macOS 10.15.7+).
Remember, Nvidia graphics processors are not supported by any version of macOS.
◦ Make sure your Breakaway Box matches the power requirement of your GPU card. Find a compatible GPU in our Graphics Card
Compatibility Chart.
◦ If you have a Breakaway Box and your GPU is not listed in the PCI entry, make sure the card is correctly seated in the PCIe slot
and the auxiliary power cable(s) are fully seated and connected to it. It is also possible that GPU is defective.
◦ If you are still experiencing problems, contact Sonnet tech support.

Figure 15: System Information detecting the graphics processor (Display Controller).

Note: Some applications may require the Prefer External GPU feature to work with an eGPU.
See: Manually selecting the external Graphics Processor (EGPU).
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